TLS 1.1 から TLS 1.2 へアップグレードする方法を教えてください

Stripe と安全にやり取りできるよう、TLS 1.0 と 1.1 のプロトコルに関するセキュリティ上の懸念に対処するため、2016年7月1日をもってこれらのプロトコルの対応を終了します。これらの懸念事項や終了する理由について詳しくは、こちらのブログ投稿を参照してください。

「Stripe no longer supports API requests made with TLS 1.1(Stripe は TLS 1.1 で作成された API リクエストをサポートしません)」というメッセージで InvalidRequestError エラーが表示される場合は、サーバのパッケージを更新して、TLS 1.2 でリクエストするようにする必要があります。

Linux のディストリビューションを調べるには cat /etc/*-release を実行してください。

  • Ubuntu または Debian の場合は、sudo apt-get update && sudo apt-get install --only-upgrade libssl1.0.0 を実行してパッケージを最新版に更新してください。

  • CentOS または RedHat の場合は、代わりに sudo yum update openssl libcurl を実行してください。

更新後に、Stripe を使用しているアプリケーションを再起動する必要があります。

Did this answer your question? Yes / No

Thanks for your feedback!

We’re sorry this didn’t answer your question. We're here to help. Contact us ▸