Stripe

Support

Upgrade OpenSSL to support TLS 1.2

If you are using Linux, you’ll need to know which distribution you are on. You can run
cat /etc/*-release to find this information.

  • If you are using Ubuntu
    • 12.04 LTS (Precise), you will need to take package updates. You can do this by running sudo apt-get update && sudo apt-get install --only-upgrade openssl, and then restarting your Stripe application. You may also need to update your libssl. You can update this by running sudo apt-get update && sudo apt-get install --only-upgrade libssl-dev.
    • 10.10 (Maverick), 11.04 (Natty), or 11.10 (Oneiric), you will need to upgrade to at least Ubuntu 12.04 (Precise). The easiest way to do this is to rebuild your server, as upgrading from these non-LTS Ubuntu versions is not supported.
    • 10.04 LTS (Lucid), you will need to upgrade to at least Ubuntu 12.04 (Precise). We recommend rebuilding your server, as the upgrade process is risky.
  • If you are using RedHat Enterprise Linux, or CentOS
    • version 6, you will need to take package updates. You can do this by running sudo yum update openssl libcurl, and restarting your Stripe application.
    • version 5, you will need to upgrade to at least Red Hat Enterprise Linux 6. We recommend rebuilding your server, as the upgrade process is risky.
  • If you are using Debian, you will need to upgrade to at least Debian 7.0 (Wheezy).
  • If you are using any other Linux variant, you will need to ensure that running openssl version gives a version of at least 1.0.1. If it does not, you will need to take package updates, and may need to upgrade to a newer version of your operating system.

If you are using OS X, we recommend that you upgrade your OpenSSL version using Homebrew. You can run brew install openssl to install the latest version of OpenSSL on your machine, then brew install python, brew install ruby, brew install php5, or brew install node to install a Homebrew-managed copy of your language. You will also need to reinstall any dependencies you had already installed.

If you are using a Windows machine, your development environment is providing your copy of OpenSSL. You can upgrade this by upgrading your development environment itself, i.e. your installation of Python, Ruby, PHP, or Node.

Was this answer helpful? Yes / No